PDA

Bekijk Volledige Versie : Domein aanvragen SIDN



BaseBoyNL
10/11/08, 12:44
Ik ben sinds kort deelnemer van SIDN.
Maar snap er allemaal nog niet echt veel van.

Zo had ik eerst problemen met de nameservers deze zijn nu verholpen als het goed is maar nu krijg ik de volgende melding.

Errors=3, Warnings=3, Informational=1

** Summary: REJECTED nieuwedomeinnaam.nl.

Some problems need to get fixed:
- In total, 3 configuration errors where found.

** Full check report:

* primary name server "ns1.eigendomein.nl."
Error: specified name server is not listed as NS record.
All public name servers for a domain must also be listed as NS records
in the zone of the domain. This domain was specified explicitly
as a name server, but not found in the zone description of the primary
name server. TE.6a
Warning: name server at 193.138.204.197 out of sync.

nieuwedomeinnaam.nl. 14400 IN NS ns2.eigendomein.nl.
Warning: hidden name server "ns2.eigendomein.nl." never used for first contact.
The zone contains an NS record for a host which is not in the list of
specified name servers. Hence, this name server will not be used to
initiate contact to the domain. It may be used in sequential lookups,
so it may still be useful.

* secondary name server "ns2.eigendomein.nl." [HIDDEN]
Info: name server looks correctly configured.

* secondary name server "ns3.eigendomein.nl."
Error: name server "ns2.eigendomein.nl." missing via IP 193.138.204.197
The primary name server listed this name server on its first IP-address.
However, this other source does not list that name.

nieuwedomeinnaam.nl. 14400 IN SOA ns1.eigendomein.nl.
root.nieuwedomeinnaam.nl.
(2008111002 4H 1H 14D 1D)
Warning: SOA for name server at 193.138.204.197 differs from the primary.
The SOA record as reported by the name server is different from the
one found at the first IP-address for the primary name server. This
means that the synchronisation between the two is not working properly.

nieuwedomeinnaam.nl. 14400 IN NS ns3.eigendomein.nl.
Error: extra name server "ns3.eigendomein.nl." listed via IP 193.138.204.197
The primary name server does not list the indicated name server
when queried at its first IP-address. However, this other source
includes that name.

** More information:
TE refers to SIDN document "Technische Eisen" (Dutch only)
http://www.sidn.nl/doc/te.pdf
RFC1035 RFC "Domain Names - Implementation and Specifications"
http://rfc.net/rfc1035.html
RFC1123 RFC "Requirements for Internet Hosts
http://rfc.net/rfc1123.html
RFC1912 RFC "Common DNS Operational and Configuration Errors"
http://rfc.net/rfc1912.html
RFC3330 RFC "Special-Use IPv4 Addresses"
http://rfc.net/rfc3330.html
RIPE203 "Recommendations for DNS SOA Values"
http://www.ripe.net/ripe/docs/ripe-203.html

** DNScheck 4.2.4, 2008/11/10 12:41:35 CET+0100

Kan iemand mij verder helpen ?

Geert-Jan
10/11/08, 13:00
stap 1: je hebt eerst de domeinnaam aangevraagd bij SIDN en daarna op je (dns) server geplaatst? ?

BaseBoyNL
10/11/08, 14:12
Server 1
ftp A 193.138.206.129
localhost A 127.0.0.1
mail A 193.138.206.129
ns1.eigendomein.nl. A 193.138.206.130
ns2.eigendomein.nl. A 193.138.206.131
ns3.eigendomein.nl. A 193.138.204.197
ns4.eigendomein.nl. A 217.170.21.223
pop A 193.138.206.129
www A 193.138.206.129
zc A 193.138.206.129
eigendomein.nl. A 193.138.206.129
eigendomein.nl. NS ns1.eigendomein.nl.
eigendomein.nl. NS ns2.eigendomein.nl.
mail MX 10
eigendomein.nl. TXT "v=spf1 a mx ip4:193.138.206.129 ?all"

Server 2
ftp A 193.138.204.197
nieuwedomeinnaam.nl. A 193.138.204.197
localhost A 127.0.0.1
mail A 193.138.204.197
pop A 193.138.204.197
smtp A 193.138.204.197
www A 193.138.204.197
nieuwedomeinnaam.nl. NS ns1.eigendomein.nl.
nieuwedomeinnaam.nl. NS ns3.eigendomein.nl.
mail MX 10
nieuwedomeinnaam.nl. TXT "v=spf1 a mx ip4:217.170.21.224 ~all"

DiedX
10/11/08, 14:14
Dan mis ik nog een derde server? Daarnaast moeten de records van server1 en server2 (en server3!) gelijk zijn aan elkaar, nu is dat niet het geval.

CQ: DNS niet op orde.

Geert-Jan
10/11/08, 14:15
..en server 4.

DiedX
10/11/08, 14:19
Het is in ieder geval fout redundant opgesteld :P

BaseBoyNL
10/11/08, 14:24
Server 1 heeft de volgende nameservers:
ns1.eigendomein.nl 193.138.206.130
ns2.eigendomein.nl 193.138.206.131

Server 2 heeft de volgende nameservers:
ns3.eigendomein.nl 193.138.204.197
ns4.eigendomein.nl 217.170.21.223

Dit is toch goed zo ?

DiedX
10/11/08, 14:36
Nee. De bedoeling is dat alle servers gelijke content hebben. Overigens heeft het geen nut om ns1 en 2 op server 1 onder te brengen: server plat zorgt er voor dat je gewoon uit de lucht bent.

Zelfs je www-records kloppen niet (!).

Sla je DNS "plat", en maak van server 1 je NS1, server2 je NS2. Ik neem aan dat deze in hetzelfde serverpark staan? (stuur maar een PB als het zo is, ik wil wel secondary voor je draaien indien nodig).

ftp A 193.138.206.129
localhost A 127.0.0.1
mail A 193.138.206.129
eigendomein.nl. IN SOA 193.138.206.130
ns1.eigendomein.nl. A 193.138.206.130
ns2.eigendomein.nl. A 193.138.204.197
pop A 193.138.206.129
www A 193.138.206.129
zc A 193.138.206.129
eigendomein.nl. A 193.138.206.129
eigendomein.nl. NS ns1.eigendomein.nl.
eigendomein.nl. NS ns2.eigendomein.nl.
mail MX 10
eigendomein.nl. TXT "v=spf1 a mx ip4:193.138.206.129 ?all"

Je SOA laat je verwijzen naar je eerste nameserver. Verder zal je uit moeten zoeken waar je exact je website en mail op wil laten lopen. Ik neem aan dat dat de 129 is.

Let op je fallback mail.

Heb je een control-panel ala Plesk? Ik wil eventueel kort er naar kijken, en kan je wel wat uitleg geven.

Geert-Jan
10/11/08, 14:40
is Direct Admin :)

BaseBoyNL
10/11/08, 14:45
Ik maak gebruik van Direct Admin.

En heb deze 2de server besteld enkel voor het draaien van een 2de name server.
Als ik een domein aan maakt was de bedoel om ns1 en ns3 te gebruiken omdat deze zijn verspreid over 2 servers.

zodat als de ene down is de anderen nog verder kon gaan.

Als je me verder kan helpen zou dat heel fijn zijn ben echt al 5 weken bezig.

DiedX
10/11/08, 14:47
Ik ben helaas geen DA-expert, maar weet zeker dat iemand hiernaar kan kijken. Weet jij of DA zelf replicatie op kan zetten? Zo ja, dan wil ik nog steeds er naar kijken ;) Wordt het script-werk, dan haak ik af :)

Geert-Jan
10/11/08, 14:47
Zo werkt dat niet helaas, en heb je ook nog eens kosten die niet hadden gehoeven...
Enfin, Diedx heeft zich aangeboden, als hij geen tijd heeft geef je nog maar eens een gil.

//Edit, we posten tegelijk....

BaseBoyNL
10/11/08, 14:54
DA heeft de functie Multi Server Setup

Zone Transfer: DA will transfer the dns info on the specified server when new domains are added and dns settings are changed.
Domain Check: DA will first check the specified server before creating a domain to ensure the domain does not exist.

Dit lijkt mij dat die dan de dns over kopieerd.

DiedX
10/11/08, 15:01
FYI: PB verstuurd aan BaseBoy. Ik zal eens kijken, mocht ik niet er uit komen, dan zal ik dat laten weten, zodat iemand met echte kennis ( ;) ) hiermee aan de slag kan.

DiedX
10/11/08, 16:42
En opgelost. DirectAdmin heeft het mooie "Multiple Server" verhaal, waarmee je DNS kan pushen. Deze heb ik aangezet. Tevens heeft BaseBoy nu een master-slave-slave oplossing voor zijn DNS :) De 3e server is mijn eigen machine, draaiend onder PowerDNS.

Leerpunten voor BaseBoy en anderen:

voor de DNS zijn je NS-Records van belang. Je NS-records laat je altijd verwijzen naar A-Records. De SOA (Start of Authoritah) wordt door DirectAdmin gefixed. Nooit een Master-Master setup draaien, DNS is daar niet voor bedoeld: updates worden altijd (of bijna altijd) door AXFR/IXFR opgelost, zo ook door DA.

En PowerDNS heerscht zoals altijd ;)