PDA

Bekijk Volledige Versie : Probleem DNS server



i-krijn
29/06/08, 10:27
Op dit moment ben ik bezig om mijn DNS server aan de praat te krijgen op mijn nieuwe dedicated server. Naar mijn idee zou deze helemaal moeten werken, maar daar lijkt het niet helemaal op. De nameserver check op sidn.nl geeft aan dat beide nameservers goed zijn geconfigureerd, maar dat er toch een onbekende error is. In het logboek van Linux is ook niks te vinden, heeft iemand een idee? De nameservers zijn 92.48.195.140 en 92.48.195.141.

Errors=1, Warnings=1, Informational=2

** Summary: REJECTED krijntanis.nl.

Some problems need to get fixed:
- Not everything could be tested, because of (technical) failures.

** Full check report:

* general reports
Failure: name server lookup failed: (unknown error)
Serious problems were encountered while checking the configured
name server. The internal error shown is not always informational.
Warning: all specified name servers are on sub-net 92.48.195.0/24
It is advisable to have at least one name server on a different network;
when one network is unavailable, the other name servers will continue to serve
the world. See TE.4

* primary name server "ns1.wimood.nl."
Info: name server looks correctly configured.

* secondary name server "ns2.wimood.nl."
Info: name server looks correctly configured.

** More information:
TE refers to SIDN document "Technische Eisen" (Dutch only)
http://www.sidn.nl/doc/te.pdf
RFC1035 RFC "Domain Names - Implementation and Specifications"
http://rfc.net/rfc1035.html
RFC1123 RFC "Requirements for Internet Hosts
http://rfc.net/rfc1123.html
RFC1912 RFC "Common DNS Operational and Configuration Errors"
http://rfc.net/rfc1912.html
RFC3330 RFC "Special-Use IPv4 Addresses"
http://rfc.net/rfc3330.html
RIPE203 "Recommendations for DNS SOA Values"
http://www.ripe.net/ripe/docs/ripe-203.html

Phu
29/06/08, 11:09
Hi,

zag dat je bij S4f zit;

Domeinnaamservers
ns1.wimood.nl 84.244.146.44
ns2.wimood.nl 84.244.146.45

Misschien dat daat het probleem ligt.
Geef maandag eens een belletje naar i3d misschien dat zij je kunnen helpen.

Iets zegt mij dat i3d hun ranges geblokkeerd heeft,er loopt een topic hierover.

clesoft
29/06/08, 11:21
Een ping naar de IP's van jouw nameservers geeft een timeout. Zegt genoeg denk ik.

i-krijn
29/06/08, 11:51
Dat die een timeout geven, dat klopt, dat zijn namelijk de oude nameservers. Het probleem is dat deze nameservers moeten worden aangepast in nieuwe nameserver, namelijk 92.48.195.140 en 92.48.195.141. Deze zijn naar mijn idee goed ingesteld.

MediaServe
29/06/08, 12:24
Dat die een timeout geven, dat klopt, dat zijn namelijk de oude nameservers. Het probleem is dat deze nameservers moeten worden aangepast in nieuwe nameserver, namelijk 92.48.195.140 en 92.48.195.141. Deze zijn naar mijn idee goed ingesteld.

Je kunt bij SIDN geen glue gebruiken, tenzij de nameservers in hetzelfde domein liggen als het te registreren domein. Dus de IP adressen bij de nameserver check moet je in dit geval altijd leeglaten.

Twee mogelijkheden:
- Andere nameserver hosts aanmaken (ns3 en ns4 bijvoorbeeld)
- Huidige nameserver hosts aanpassen naar de nieuwe IP adressen

Stewie
29/06/08, 12:44
Iets zegt mij dat i3d hun ranges geblokkeerd heeft,er loopt een topic hierover.
Wij blokkeren geen ranges. :)

dreamhost_nl
29/06/08, 15:32
Dat leek me ook al vreemd ja... :)
Heb je de nieuwe glue records al ingesteld voor wimood.nl ?
Zo niet, eerst doen. Zo wel, nog even wachten tot de DNS propagatie heeft plaatsgevonden. Daarna zal de SIDN automatisch de correcte IP-adressen gaan gebruiken voor je DNS records.

i-krijn
29/06/08, 16:45
Prima, dan weet ik al wat er aan de hand is. Aangezien de ns1.wimood.nl en ns2.wimood.nl eerst moeten resolven naar de IP adressen van de nieuwe DNS server, moet wimood.nl eerst worden omgezet. Op het moment dat wimood.nl draait via de nieuwe DNS, moeten de andere domeinen ook worden omgezet.

Klopt het dat .com/.eu/.net geen gebruik maken van het invoeren van IP adressen bij de DNS gegevens. Ik zie namelijk in de whois overal alleen de hostnames staan.

dreamhost_nl
29/06/08, 17:42
Het invoeren van IP-adressen is alleen nodig indien het glue records betreft. Anders hoeft dat eigenlijk bij geen enkele registry.

Phu
29/06/08, 23:34
Prima, dan weet ik al wat er aan de hand is. Aangezien de ns1.wimood.nl en ns2.wimood.nl eerst moeten resolven naar de IP adressen van de nieuwe DNS server, moet wimood.nl eerst worden omgezet. Op het moment dat wimood.nl draait via de nieuwe DNS, moeten de andere domeinen ook worden omgezet.

Klopt het dat .com/.eu/.net geen gebruik maken van het invoeren van IP adressen bij de DNS gegevens. Ik zie namelijk in de whois overal alleen de hostnames staan.

Als je toch bezig bent ns2 te veranderen waarom niet een 2e dns in een andere range
of andere netwerk ?

dreamhost_nl
30/06/08, 10:31
Hoogstwaarschijnlijk (correct me if I'm wrong) omdat beide DNS servers op dezelfde server draaien.