PDA

Bekijk Volledige Versie : Hulp met domeinnaam



crispy78
24/12/07, 15:03
Allereerst allemaal goede kerstdagen gewenst en alvast de beste wensen voor 2008.

Ik heb een probleem met een domeinnaam.
Samen met een vriend hebben wij een VPS bij Strato (binnenkort een DDS), en betrekken wij onze domeinnamen bij TransIP.

Ik heb bij TransIP als primaire nameserver aangegeven de nameserver van ons domein (die wij via Plesk hebben aangemaakt), als secundaire nameserver wil ik die van TransIP laten draaien. Na wat pogingen heb ik toch enkele tips nodig, dit omdat SiDN onze setup steeds afkeurt.

Bij de Nameservers van TransIP staat nu:
Nameservers:
ns.domein.nl 85.214.xx.xxx
ns1.transip.net 80.69.69.69
ns2.transip.net 84.246.22.10

De DNS-records bij TransIP staan dan als volgt ingesteld:
@ 1 dag NS ns.domein.nl. (standaard)
@ 1 dag NS ns1.transip.net. (standaard)
@ 1 dag NS ns2.transip.net. (standaard)
localhost 1 dag A 127.0.0.1 (standaard)
@ 1 dag A 85.214.xx.xxx
@ 1 dag MX 10 @
@ 1 dag MX 20 relay.transip.nl.
ftp 1 dag CNAME @
mail 1 dag CNAME @
www 1 dag CNAME @

Via Plesk (Strato) heb ik ingesteld het volgende (standaard):
85.214.xx.xxx / 24 PTR domein.nl.
domein.nl. NS ns.domein.nl.
domein.nl. A 85.214.xx.xxx
domein.nl. MX (10) mail.domein.nl.
ftp.domein.nl. CNAME domein.nl.
mail.domein.nl. A 85.214.xx.xxx
ns.domein.nl. A 85.214.xx.xxx
webmail.domein.nl. A 85.214.xx.xxx
www.domein.nl. CNAME domein.nl.

Ik heb in Plesk (Server -> DNS -> Common Allow Zone Transfer ACL) de volgende IP-adressen toegang gegeven tot de DNS:
80.69.67.44
80.69.67.67
80.69.69.69
84.246.22.10

Wanneer ik de SIDN Nameserver check doe dan krijg ik het volgende:
* primary name server "ns.domein.nl." [BROKEN]
Failure: name server cannot be reached: query timed out
The name server could not be contacted, which may be due to temporary
technical problems or global DNS configuration mistakes. The internal
error shown is not always informational.

* secondary name server "ns1.transip.net."
Info: name server looks correctly configured.

* secondary name server "ns2.transip.net."
Info: name server looks correctly configured.

Heeft iemand tips?
De bedoeling is (want dat schijnt te kunnen) dat de nameserver van TransIP de gegevens van Plesk (Strato) overnemen, op de manier heb ik 2 unieke nameservers draaien (nodig voor .nl-domeinen) en heb ik maar 1 ip-adres nodig voor mijn werkelijke domeinnaam.

dreamhost_nl
24/12/07, 15:15
Heb je glue voor je eerste DNS server (ns.domein.nl) wel aangezet/ingesteld?

Xolphin
24/12/07, 17:59
Waarschijnlijk blokkeer je de toegang tot je DNS in je firewall...

crispy78
24/12/07, 18:39
Heb je glue voor je eerste DNS server (ns.domein.nl) wel aangezet/ingesteld?

Ik denk dat hier het probleem zit.
TransIP verwijst wel naar Strato alleen Strato verwijst niet naar TransIP.
(Althans ik denk dat een Glue-record dat doet).
Via Plesk kan ik alleen records maken die verwijzen naar het eigen domein.
Ik kan dus niet een A record maken die verwijst naar NS1.transip.net

dreamhost_nl
24/12/07, 19:13
ns.domein.nl is dat niet de naam van je eigen DNS server dan?
De SIDN zal niet het IP-adres van ns.domein.nl weten zonder dat dat ooit 'ns is ingevoerd; dat is kortweg een "glue" record. Als je dus het IP-adres niet meegeeft zal het niet werken.

crispy78
25/12/07, 14:23
Bij TransIP heb ik aangegeven dat ik hun nameservers secudary wil hebben draaien.
Ik heb bij de primary nameserver mijn eigen nameserver gemeld (ns.domein.nl) met daarbij het daarbij behorende IP-adres 85.214.xx.xxx en heb vervolgens als secundary en als thrird nameserver ns1.transip.net en ns2.transip.net met de daarbij behorende IP-adressen.

Het rare is dat de nameservers van TransIP wel goed geconfigureerd zijn, alleen bij mij geeft hij "BROKEN" aan, als ik het zooitje invoer bij de SIDN controlle-tool voor nameservers. Bij de Tool geef ik ook bij mijn nameserver het bijbehorende IP-adres op. Ik denk dus dat er een fout zit in mijn DNS-configuratie. Als ik zo die DNS-gegevens bekijk dan zit er in mijn DNS-configuratie meer A-records dan in die van TransIP, waar meer CNAME-records zitten... Al zou dat volgens mij niet mogen uitmaken. Plesk DNS is standaard configuratie, waar ik in mijn tijd met FlexServers ook mee werkte (alleen kon ik daar beide DNS-servers draaien omdat ik 2 ip-adressen kreeg).

Xolphin
26/12/07, 00:15
Ik denk nog steeds dat het je firewall is.

Misschien handig als je hier gewoon het IP geeft van je DNS server en het domeinnaam waar het om gaat, dan kunnen we kijken waar het probleem zit.

crispy78
26/12/07, 06:06
Ik heb mijn firewall nagekeken en deze blokkeerde inderdaad verkeer.
Daarna weer een check uitgevoerd maar helaas.

Het domein waar het om gaat is chondemo.nl
De aangemaakte nameserver is ns.chondemo.nl en zit op ip-adres 85.214.49.252.

Costeijn
26/12/07, 09:42
Heb je de nameservers van transip wel in je PLESK dns gezet?

dreamhost_nl
26/12/07, 12:12
Errors=1, Warnings=0, Informational=0

** Summary: REJECTED chondemo.nl.

Some problems need to be fixed:
- Not everything could be tested, because of (technical) failures.

** More information:
TE refers to SIDN document "Technische Eisen" (in dutch)
http://www.sidn.nl/doc/te.pdf
RFC1035 RFC "Domain Names - Implementation and Specifications"
http://rfc.net/rfc1035.html
RFC1123 RFC "Requirements for Internet Hosts"
http://rfc.net/rfc1123.html
RFC1912 Common DNS Operational and Configuration Errors
http://rfc.net/rfc1912.html
RIPE203 Recommendations for DNS SOA Values
http://www.ripe.net/ripe/docs/ripe-203.html

** Full check report:

* primary name server "ns.chondemo.nl." [BROKEN]
Failure: name server cannot be reached: query timed out
The name server could not be contacted, which may be due to temporary
technical problems or global DNS configuration mistakes. The internal
error shown is not always informational.

* secondary name server "ns1.transip.net."
Info: name server looks correctly configured.

* secondary name server "ns2.transip.net."
Info: name server looks correctly configured.


Lijkt me indd. ook een probleem met de firewall (of named die niet draait uiteraard).

Xolphin
26/12/07, 13:27
Ik krijg er inderdaad ook geen verbinding mee. Als ik jou was zou ik de volgende dingen even controleren:

- Zorg ervoor dat bind luistert op poort 53 met query-source address * port 53;
- Zorg ervoor dat bind luistert naar aanvragen die van buiten komen, standaard is het ingesteld dat hij alleen naar localhost luistert.
- Zorg er voor dat je firewall alles voor poort 53 door laat.

crispy78
26/12/07, 13:59
Heb je de nameservers van transip wel in je PLESK dns gezet?

Volgens mij wel :

Ik heb in Plesk (Server -> DNS -> Common Allow Zone Transfer ACL) de volgende IP-adressen toegang gegeven tot de DNS:
80.69.67.44
80.69.67.67
80.69.69.69
84.246.22.10


In mijn named.conf.plesk-zones staat het volgende:
zone "chondemo.nl" {
type master;
file "chondemo.nl';
allow-transfer {
85.214.49.252
common-allow-transfer;
};

Als ik het ip-adres in allow-transfer verander in any dan veranderd dat niets.

In mijn named.conf staat:
listen-on port 53 { 127.0.0.1; };
listen-on-v6 { any; };

Als ik bij het eerste (listen-on port) 127.0.0.1 verander in any dan maakt dat helemaal niets uit.

Enige tips (walkthru's) zijn welkom.