PDA

Bekijk Volledige Versie : Apache Problemen



WeirdEye
20/01/07, 13:45
Weer een vraag van mij...:(

CentOS geinstalleerd, KerioMailServer orop, bij de installatie van CentOS al aangegeven dat er een webserver opmoet, maar na alles updates ging ik naar localhost, ho maar, gecontroleerd of de webserver draaide door hem se herstarten, kreeg ik deze error:


[root@mecurius oosterhof]# /etc/init.d/httpd restart
Starten van httpd: [Sat Jan 20 12:33:59 2007] [warn] The Alias directive in /etc /httpd/conf/httpd.conf at line 499 will probably never match because it overlaps an earlier AliasMatch.
(98)Address already in use: make_sock: could not bind to address [::]:443
no listening sockets available, shutting down
Unable to open logs
[MISLUKT]

Toen KerioMailServer geinstalleerd, ga ik naar localhost krijg ik direct de inlog van kerio, maar die wil ik kunnen benaderen via een subdomein met virtualhost in apache.

Mijn vraag is dus, hoe krijg ik apache goed draaiend???:X

smurf
20/01/07, 14:02
/usr/sbin/lsof -i:443

Processen die die poort gebruiken verschijnen.

Je kan ze killen door:

kill -9 procesnummer

te doen

Dan kan je apache restarten.

Het is wel verstandig na te gaan waarom dit zo is.

wonko
20/01/07, 14:04
kerio zal vermoedelijk zelf een webserver aan boord hebben en zal deze eerst gestart hebben.

Afhankelijk van hoe kerio ineen steekt, kan je de config van kerio mixen met de andere van apache, ofwel dien je kerio gewoon op een andere poort te draaien (en dan misschien met de proxy-module deze op een subdomein beschikbaar maken)...

WeirdEye
20/01/07, 14:07
Proces kill wil niet, Kerio zou idd een eigen server kunnen draaien, dat zal ik even uitzoeken
[edit]
Kerio uitgzet, httpd proberen te starten, maar nu een andere error:

[root@mecurius oosterhof]# /etc/init.d/httpd start
Starten van httpd: [Sat Jan 20 13:05:52 2007] [warn] The Alias directive in /etc/httpd/conf/httpd.conf at line 499 will probably never match because it overlaps an earlier AliasMatch.


Ook geprobeerd te killen, maar komt met dat het een onbekend proces is...

It-Biz
20/01/07, 15:14
beetje karige info, op "line 499" staat?

Peuk
20/01/07, 16:00
Heb ik ook eens gehad, gewoon een reboot gegeven en toen werkte het weer.